Auteur Topic: Knoppen werken niet in wsWebcamPagecomplex.php  (gelezen 595 keer)

roncpjovertoom

  • Gast
Knoppen werken niet in wsWebcamPagecomplex.php
« Gepost op: 14 april 2016, 10:45:08 »
Hoi mede forum leden,

Wie kan mij helpen met de fout van knoppen Static picture, SecuritySpy, Ivideon, als ik daar op klik geeft de website een dikke foutmelding in plaats van het live video van de webcam weer te geven.

De fout komt voor in de laste paar versies van het leuven template zelf draai ik met versie 2.8f met alle tevredenheid.

Of heeft iemand op dit forum een goed werkende wsWebcamPagecomplex.php ?

Alvast mijn dank voor jullie hulp.

wvdkuil

  • Administrator
  • Hero Member
  • *****
  • Berichten: 688
    • Bekijk profiel
    • Template Support
Re: Knoppen werken niet in wsWebcamPagecomplex.php
« Reactie #1 Gepost op: 15 april 2016, 16:26:59 »
Hoi mede forum leden,

Wie kan mij helpen met de fout van knoppen Static picture, SecuritySpy, Ivideon, als ik daar op klik geeft de website een dikke foutmelding in plaats van het live video van de webcam weer te geven.

De fout komt voor in de laste paar versies van het leuven template zelf draai ik met versie 2.8f met alle tevredenheid.

Of heeft iemand op dit forum een goed werkende wsWebcamPagecomplex.php ?

Alvast mijn dank voor jullie hulp.
Vanaf release 2.8 is er eigenlijk geen behoefte meer voor een pagina met een stilstaand plaatje en een webcam-feed.
Immers als je op het kleine webcam plaatje klikt in de zij-kolom dan wordt de kleine afbeelding al vergroot getoond.
Eigenlijk zou de link (het groene pijltje) dus direct naar een verborgen pagina (hide = "yes") met de feed kunnen gaan.

Maar omdat er steeds meer mensen komen met meerdere webcams moet er toch van alles gemaakt worden.

Hierbij een eerste test-versie van een webcam pagina met stilstaand beeld en een feed d.m.v. knoppen.

1. Maak een backup van je huidige webcam pagina script.
2. Gebruik om te testen eerst het script wsWebcamPageComplex.php
Hernoem dat naar wsWebcamPage.php en test of het geladen wordt en of de knoppen werken.
De feed is een test-feed naar een niet meer bestaande camera.

3. Gebruik dan het andere script waar ik alvast de "webcam7" code van je vorige versie heb ingevoegd.
Die code werkt niet, maar ik weet dus niet of dat klopt.
VRAAG: Staat er ergens eenwerkende pagina op een oude site?

===

De teksten van de knoppen 'Static picture' en 'Live feed' kun je het beste in de vertaal tabellen veranderen.
Dan hoeft dat niet bij volgende versies.

===

Als dit werkt, dan moet er dus een oplossing komen voor meerdere webcams, jij hebt er 2.
VRAAG:  Ik neem tenminste aan dat je voor beide camera's een aparte webcam feed hebt?

===

Vanaf morgen-middag tot woensdag ben ik eigenlijk niet beschikbaar voor hulp, maar wellicht kom je er zo ook wel uit.

Wim




« Laatst bewerkt op: 15 april 2016, 16:37:01 door wvdkuil »
Vantage VUE / MB-Nano https://weer.sluispark.be/
Vantage VP2 / USB logger / Meteobridge https://www.weerstation-herent.be/

Support Leuven-Template at  https://support.leuven-template.eu/
Support PWS_Dashboard (HWS-Template) https://pwsdashboard.com/

roncpjovertoom

  • Gast
Re: Knoppen werken niet in wsWebcamPagecomplex.php
« Reactie #2 Gepost op: 17 april 2016, 18:17:43 »
Hoi mede forum leden,

Wie kan mij helpen met de fout van knoppen Static picture, SecuritySpy, Ivideon, als ik daar op klik geeft de website een dikke foutmelding in plaats van het live video van de webcam weer te geven.

De fout komt voor in de laste paar versies van het leuven template zelf draai ik met versie 2.8f met alle tevredenheid.

Of heeft iemand op dit forum een goed werkende wsWebcamPagecomplex.php ?

Alvast mijn dank voor jullie hulp.
Vanaf release 2.8 is er eigenlijk geen behoefte meer voor een pagina met een stilstaand plaatje en een webcam-feed.
Immers als je op het kleine webcam plaatje klikt in de zij-kolom dan wordt de kleine afbeelding al vergroot getoond.
Eigenlijk zou de link (het groene pijltje) dus direct naar een verborgen pagina (hide = "yes") met de feed kunnen gaan.

Maar omdat er steeds meer mensen komen met meerdere webcams moet er toch van alles gemaakt worden.

Hierbij een eerste test-versie van een webcam pagina met stilstaand beeld en een feed d.m.v. knoppen.

1. Maak een backup van je huidige webcam pagina script.
2. Gebruik om te testen eerst het script wsWebcamPageComplex.php
Hernoem dat naar wsWebcamPage.php en test of het geladen wordt en of de knoppen werken.
De feed is een test-feed naar een niet meer bestaande camera.

3. Gebruik dan het andere script waar ik alvast de "webcam7" code van je vorige versie heb ingevoegd.
Die code werkt niet, maar ik weet dus niet of dat klopt.
VRAAG: Staat er ergens eenwerkende pagina op een oude site?

===

De teksten van de knoppen 'Static picture' en 'Live feed' kun je het beste in de vertaal tabellen veranderen.
Dan hoeft dat niet bij volgende versies.

===

Als dit werkt, dan moet er dus een oplossing komen voor meerdere webcams, jij hebt er 2.
VRAAG:  Ik neem tenminste aan dat je voor beide camera's een aparte webcam feed hebt?

===

Vanaf morgen-middag tot woensdag ben ik eigenlijk niet beschikbaar voor hulp, maar wellicht kom je er zo ook wel uit.

Wim

Bedankt voor het voor onderzoek Wim, ik heb je bestand webcam_feeds.zip gedownload en zal er vanavond even mee aan de slag.
Alvast mijn grote dank voor het uitzoeken en je uitleg ik hou je en de andere forum leden op de hoogte of me gelukt is.
« Laatst bewerkt op: 26 april 2016, 16:20:00 door Meteo Oudkarspel »

roncpjovertoom

  • Gast
Re: Knoppen werken niet in wsWebcamPagecomplex.php
« Reactie #3 Gepost op: 17 april 2016, 20:37:02 »
Hoi Wim en de overige forum leden,

Ik kan jullie melden dat het werkt voor 100%, ik ben weer helemaal :)
 
En in _my_texts/wsLanguage-nl-local.txt  heb ik de vertaling ge plaatst. En dat werkt ook.


Op je vraag of ik nog een oude weer site heb, nee alleen de nieuwste versie van template heb ik draaien.
Afgelopen weekend stond me webcam stream server uit dus klopt dat je geen beeld kreeg.
« Laatst bewerkt op: 26 april 2016, 19:22:17 door Meteo Oudkarspel »